Data Folder Wiped
Incident Report for RiiConnect24
Resolved
We're back up. Not even deleting all our files could stop us from coming back in couple of hours. :-)

The issue with the bot which had been responsible for the issue's patched but we are having connection issues with the bot and it might disrupt performance. We'll try to fix ASAP
Posted Jul 28, 2023 - 01:20 CDT
Update
We have found the issue. The RiiConnect24 Bot was updated yesterday and there had been a command to execute bash commands whether or not you're an admin on the bot thanks to the person which rewrote it. Evidently someone used the bash command to delete everything in the website root. This is REALLY BAD and will be patched on the bot immediately. Whoever did this can laugh about it how much they want, and this is entirely our fault for deploying the bot with the vulnerability in there. Hopefully they didn't grab our MySQL backups, which I'm doubtful they have (even if they did, there's nothing very personal on it except mail, which your credentials for mail are salted SHA512 hashes and cannot easily be cracked.)

Again, thankfully we have backups and they are restoring right now.
Posted Jul 27, 2023 - 21:54 CDT
Identified
Apparently out of nowhere our root folder with data files got wiped resulting in 404 errors for News/Forecast/Check Mii Out/Nintendo/Everybody Votes Channel. Thankfully there's a backup that has been made 4 days ago and it's restoring as we speak. An investigation will be made as to the reason why it got wiped and to prevent it in the future. BACK UP YOUR FILES. OR ELSE THE PROJECT WOULD'VE CRUMBLED DOWN IF WE DIDN'T HAVE BACKUP.
Posted Jul 27, 2023 - 21:35 CDT
This incident affected: Services (Forecast Channel, News Channel, Everybody Votes Channel, Nintendo Channel, Check Mii Out Channel/Mii Contest Channel) and Server (RiiConnect24 Main Server).