General service unavailability
Incident Report for RiiConnect24
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 18:47 CDT
Update
All the affected services excepting Wii Mail have fully recovered. We still are working on Wii Mail.
Posted Sep 27, 2021 - 17:47 CDT
Monitoring
Wii Mail has been disabled for the time being to investigate what is causing all the connections to stay stuck. Other services seem to be working fine and will be monitored.
Posted Sep 27, 2021 - 16:57 CDT
Identified
We've noticed a lot of active connections at the same time that are not getting completed to the Mail Service. This seems to be contributing to the attack.
Posted Sep 27, 2021 - 16:47 CDT
Update
The attacker's IP has been blocked from accessing any of our services. We're monitoring now.
Posted Sep 27, 2021 - 16:23 CDT
Monitoring
We have raised some resource limits and applied some mitigation. We'll monitor how this evolves.
Posted Sep 27, 2021 - 15:53 CDT
Identified
We suspect a DoS attack is overloading our webserver resources.
Posted Sep 27, 2021 - 15:48 CDT
Update
We are continuing to investigate this issue.
Posted Sep 27, 2021 - 15:40 CDT
Investigating
We are currently investigating why some web services are not available.
Posted Sep 27, 2021 - 15:36 CDT
This incident affected: Patchers (RiiConnect24 Patcher - Patching, RiiConnect24 Patcher - Error reporting, Mail Patcher, WiiWare Patcher), Services (Forecast Channel, News Channel, Everybody Votes Channel, Nintendo Channel, Check Mii Out Channel/Mii Contest Channel), and Wii Mail (Server).